Post

2 followers Follow
0

Charging does not work? Shuts down after 30 seconds

Hello,

Iris 360 is not charging I guess - there is not light indication that anything is happening and when I turn it on it doesn't last more that 30 seconds and then shuts down again saying battery is 6 %.

I've gone through manual and there is not mention of what actually happens with display when device is charging. I see blue led lights sometimes, sometimes orange ones before it shuts down.

 

What to do?

Thanks

Please sign in to leave a comment.

5 comments

0

Hi Mijo,

I see that you also raised a support ticket around this issue - I have just responded via the ticket, can you please review and let me know if you require further assistance?

0 votes
0

Certainly - when logged into your Support Portal account, you can click on your name in the top right corner and select "My Activities", which includes support tickets.

You should also receive email notifications on any updates, please check and make sure these aren't going into your Spam/Junk folder.

However, you can also access the ticket by using the below direct link:

https://nctech.zendesk.com/hc/en-us/requests/6688

0 votes
0

Still nothing Jamie, I am inside of my account but ticket activities are empty. I get this message when following ticket link from here or my inbox: 

OOPS

The page you were looking for doesn't exist

You may have mistyped the address or the page may have moved

0 votes
0

Hi Mijo,

You have created two separate accounts on our Support Portal - your ticket was raised using one of these, and the thread started with the other, this is why you don't see the ticket.

I will change the support ticket over to the email address that you are using here (ry********@gmail.com) and update it, you'll then get a notification and should be able to see it under "activities".

0 votes